[Fix] The used table type doesn’t support FULLTEXT indexes

Stop worrying about your server.

cPanel/Plesk Server Management for just $59/mo with Unlimited tickets, Unlimited admin hours, Security audits, 24×7 monitoring and lot more 

cPanel Server Management  $59/mo Click here

Plesk Server Management $59/mo Click here

[Fix] The used table type doesn’t support FULLTEXT indexes:

Sometimes you will get this error while restoring database backup using mysql command from command line of the server. This is because of some compatibility issues with the mysql running on the server.

If the backup is taken from another server then you need to check the mysql versions on both the servers. Mysql version is recommended to 5.5 or 5.6 to avail most of the features. You can check current mysql version using the command,

mysql --version

The result of the command will be like,

[email protected] [~]# mysql --version
mysql Ver 14.14 Distrib 5.5.42, for Linux (x86_64) using readline 5.1

If the mysql version is older than 5.5 then you need to upgrade MySQL version to 5.5 or 5.6 to fix the issue. Only MySQL 5.6 will support FULLTEXT indexes for both the table types.

Also if you are getting the error with MySQL version 5.5 or less then you can fix the issue by modifying the table type. For that, issue the following command to mysql for changing the type of table,

ALTER TABLE <table name> ENGINE = MYISAM

This will change the table type to MYISAM and fix the error with FULLTEXT.

Also we recommend to keep the MYSQL version 5.6 on your server.

That’s all.

If you need our help to fix any issues on your server. Please feel free to contact us, simply email to [email protected]

Monthly server support with Unlimited tickets, 24×7 monitoring, Security Audit and lot more for just $59 

Server Management at just $59

Leave a Reply

Your email address will not be published. Required fields are marked *