MySQL conflict while updating Cpanel [WHM 11.34 update]

Are you interested for monthly server support with Unlimited tickets, 24×7 monitoring, Security Audit and lot more ? please check our Monthly server support plans

While updating cPanel server from 11.34 -> 11.36 sometimes you will get the following error,

[20130129.020655] Testing if the newly downloaded RPMS can be installed without conflict [20130129.020655] Testing RPM transaction [20130129.020656] error: Failed dependencies: [20130129.020656] MySQL conflicts with mysql-5.0.77-4.el5_6.6.i386 [20130129.020656] W Exit Code: 254 [20130129.020656] ***** FATAL: Test install failed: error: Failed dependencies: [20130129.020656] MySQL conflicts with mysql-5.0.77-4.el5_6.6.i386 [20130129.020656] The Administrator will be notified to review this output when this script completes [20130129.020656] E Error testing if the RPMs will install: Died at /usr/local/cpanel/scripts/updatenow.static line 12517. [20130129.020656] E Detected events which require user notification during updatenow. Will send iContact the log

You can fix this error by doing below fix

1. Edit cPanel configuration file

open the file : /var/cpanel/cpanel.config from commandline using,
vi /var/cpanel/cpanel.config

and find the below section

====================
mysql-version=5.1
====================

Then replace it with

====================
mysql-version=5.5
====================

You can now run upcp command without any error [MySQL conflict]

Need our help to fix the issue ? Submit Support Ticket Now

View Server Administration Packages

Leave a Reply

Your email address will not be published. Required fields are marked *