Plesk Downgrade from php5.4 to 5.3

Are you interested for monthly server support with Unlimited tickets, 24×7 monitoring , Security Audit and lot more ? please check our Monthly server support plans

Plesk Downgrade from php5.4 to 5.3 If atomic repository is enabled on your server first you need to exclude php5.4 in /etc/yum.conf

vi /etc/yum.conf

add

exclude=php*5.4*

Than run

yum downgrade $(rpm -qa --queryformat="%{name} \n" |grep ^php)

You might get the below error of php-fpm is installed

Error: Package: psa-phpfpm-configurator-1.0.0-cos6.build115130618.12.x86_64 (@PSA_11_5_30-dist)
Requires: php-fpm >= 5.3.9
Removing: php-fpm-5.4.21-27.el6.art.x86_64 (@atomic)
php-fpm = 5.4.21-27.el6.art
Downgraded By: php-fpm-5.3.3-23.el6_4.x86_64 (updates)
php-fpm = 5.3.3-23.el6_4
Available: php-fpm-5.3.3-22.el6.x86_64 (base)
php-fpm = 5.3.3-22.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

In that case remove php-fpm from plesk. I suggest you to remove php-fpm and nginx together Once its done run the command again

yum downgrade $(rpm -qa --queryformat="%{name} \n" |grep ^php)

All should be good 🙂 Need our help to fix the issue ? Submit Support Ticket Now

View Server Administration Packages

Leave a Reply

Your email address will not be published. Required fields are marked *